BetterCloud Log-in Issue
Incident Report for BetterCloud
Resolved
We have resolved the issue that was preventing customers from logging into the new BetterCloud interface, and everything should back to normal. We appreciate your patience! If you have any questions, please contact Support: support@bettercloud.com
Posted Aug 15, 2017 - 18:55 EDT
Investigating
We are currently investigating an issue that is preventing customers from logging into the new BetterCloud interface. We apologize for any inconvenience and will provide another update as soon as possible. If you have any questions, please contact Support: support@bettercloud.com
Posted Aug 15, 2017 - 18:23 EDT