All Systems Operational
BetterCloud ? Operational
Core Services ? Operational
Alerts Operational
Directory Operational
Files Operational
Workflows Operational
Privileges Operational
Audit Logs Operational
Platform API Operational
Applications Operational
Dashboard Operational
Data Protection ? Operational
Global Search Operational
Grids / User Interface Operational
Workflow Activity Feed ? Operational
Content Scanning Operational
Integrations Operational
Atlassian Operational
Azure AD Operational
BambooHR Operational
Box Operational
Dropbox Operational
Google Operational
Namely Operational
Office 365 Operational
Okta Operational
OneLogin Operational
Salesforce Operational
Slack Operational
Zendesk Operational
Zoom Operational
Workday Operational
Slack Enterprise Grid Operational
Live Chat Widget Operational
BetterCloud for G Suite ? Operational
General Information ? Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Scheduled Maintenance
BetterCloud is scheduled to undergo routine maintenance on Wednesday, April 24, 2024 from 8:00pm to 10:00pm EST. Within this window, certain features within g.bettercloud.com may not work as expected. If you have any questions, feel free to reach out to support at support@bettercloud.com
Posted on Apr 18, 2024 - 15:58 EDT
Past Incidents
Apr 23, 2024

No incidents reported today.

Apr 22, 2024

No incidents reported.

Apr 21, 2024

No incidents reported.

Apr 20, 2024

No incidents reported.

Apr 19, 2024
Resolved - We have resolved the issue that was affecting Workflow Builder in app.bettercloud.com. We appreciate your patience! If you have any questions, please contact Support: support@bettercloud.com
Apr 19, 19:20 EDT
Investigating - We are currently investigating an issue affecting Workflow Builder in app.bettercloud.com. Certain Workflows are not accessible via the Workflow > Manager page. We apologize for any inconvenience and will provide another update as soon as possible. If you have any questions, please contact Support by emailing support@bettercloud.com
Apr 19, 18:33 EDT
Apr 18, 2024

No incidents reported.

Apr 17, 2024

No incidents reported.

Apr 16, 2024
Resolved - We have resolved the issue that was affecting the loading of the Group details list. This issue was also visible when using the Global Search featureWe appreciate your patience! If you have any questions, please contact Support: support@bettercloud.com
Apr 16, 16:51 EDT
Update - We have identified and fixed an issue loading the Group details list. This issue was also visible when using the Global Search feature. We currently monitoring for stability and will provide another update shortly. We apologize for any inconvenience this may have caused. If you have any questions, please contact Support by emailing support@bettercloud.com
Apr 16, 14:47 EDT
Monitoring - We have identified and fixed an issue loading the Group details list. This issue was also visible when using the Global Search feature. We currently monitoring for stability and will provide another update shortly. We apologize for any inconvenience this may have caused. If you have any questions, please contact Support by emailing support@bettercloud.com
Apr 16, 12:52 EDT
Apr 15, 2024

No incidents reported.

Apr 14, 2024

No incidents reported.

Apr 13, 2024

No incidents reported.

Apr 12, 2024

No incidents reported.

Apr 11, 2024

No incidents reported.

Apr 10, 2024
Completed - The scheduled maintenance has been completed.
Apr 10, 23:04 EDT
In progress - Our team is continue to verify the changes to g.bettercloud.com. We apologize for the inconvenience. We will provide updates as necessary.
Apr 10, 21:55 EDT
Verifying - Verification is currently underway for the maintenance items.
Apr 10, 20:56 EDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 10, 20:00 EDT
Scheduled - BetterCloud is scheduled to undergo routine maintenance on Wednesday, April 10th, 2024 from 8:00pm to 9:00pm EST. Within this window, certain features within g.bettercloud.com may not work as expected. If you have any questions, feel free to reach out to support at support@bettercloud.com
Mar 27, 12:38 EDT
Apr 9, 2024

No incidents reported.