BetterCloud Outage
Incident Report for BetterCloud
Resolved
We have resolved the issue and all functionality has been restored. If you have any questions, please contact the Support Team
Posted Apr 23, 2019 - 19:33 EDT
Monitoring
We have taken action to fix an issue that was preventing parts of BetterCloud from loading as expected, and we are monitoring to ensure that everything is back to normal. We will provide another update when we consider this incident resolved. If you have any questions, please contact Support: support@bettercloud.com
Posted Apr 23, 2019 - 19:10 EDT
This incident affected: BetterCloud (Alerts, Directory, Workflows).