Drive Delays in BetterCloud for G Suite
Incident Report for BetterCloud
Resolved
We have resolved the issue that was causing delayed Drive syncs in BetterCloud for G Suite. We appreciate your patience. If you have any questions, please contact Support: support@bettercloud.com
Posted 12 months ago. May 04, 2018 - 17:53 EDT
Monitoring
Drive documents are syncing at a delay into BetterCloud for G Suite. We are monitoring as we process queued syncs and will provide another update as soon as we can. If you have any questions, please contact Support: support@bettercloud.com
Posted 12 months ago. May 04, 2018 - 11:19 EDT