Can't Access BetterCloud
Incident Report for BetterCloud
Resolved
We have resolved the issue that was preventing users from accessing BetterCloud. We appreciate your patience. If you have any questions, please contact Support: support@bettercloud.com
Posted about 1 year ago. Aug 14, 2018 - 14:36 EDT
Monitoring
We have taken action to fix the issue that was preventing users from accessing BetterCloud, and we are monitoring to ensure that everything is back to normal. If you have any questions, please contact Support: support@bettercloud.com
Posted about 1 year ago. Aug 14, 2018 - 14:23 EDT
Identified
We have identified the root cause of the issue that is preventing users from accessing BetterCloud, and our team is working on a fix. If you have any questions, please contact Support: support@bettercloud.com
Posted about 1 year ago. Aug 14, 2018 - 13:40 EDT
Investigating
We are currently investigating an issue that is preventing users from accessing BetterCloud. We apologize for any inconvenience and will provide another update as soon as we have more information. If you have any questions, please contact Support: support@bettercloud.com
Posted about 1 year ago. Aug 14, 2018 - 13:24 EDT
This incident affected: BetterCloud (Core Services).