Workflows Delay
Incident Report for BetterCloud
Resolved
We have resolved the issue that was delaying Workflows, and everything should be back to normal. We appreciate your patience! If you have any questions, please contact Support: support@bettercloud.com
Posted Jun 06, 2019 - 15:56 EDT
Investigating
We are currently investigating an issue that is causing a Workflows delay. We apologize for any inconvenience and will provide another update as soon as possible. If you have any questions, please contact Support: support@bettercloud.com
Posted Jun 06, 2019 - 15:31 EDT
This incident affected: BetterCloud (Workflows).