Cannot Access BetterCloud
Incident Report for BetterCloud
Resolved
We have resolved the issue that was preventing users from accessing BetterCloud. If you have any questions, please contact Support: support@bettercloud.com
Posted 2 months ago. Dec 21, 2018 - 12:51 EST
Identified
We have identified the root cause of an issue that is preventing users from accessing BetterCloud, and our team is working on a fix. We will provide another update as soon as we have more information. If you have any questions, please contact Support: support@bettercloud.com
Posted 2 months ago. Dec 21, 2018 - 11:58 EST
This incident affected: BetterCloud (Core Services).