Delayed Alerts
Incident Report for BetterCloud
Resolved
We have completed processing all tasks in our backlog and Alerts are now triggering at a normal rate. We appreciate your patience! If you have any questions, please contact Support: support@bettercloud.com
Posted 10 months ago. May 09, 2018 - 06:22 EDT
Monitoring
We have taken action to fix an issue that was causing Alerts to trigger at a delay, and we are monitoring as we process through the backlog. If you have any questions, please contact Support: support@bettercloud.com
Posted 10 months ago. May 08, 2018 - 16:41 EDT