Discover Application UI Not Loading Properly
Incident Report for BetterCloud
Resolved
We have resolved the issue that was affecting the visibility of the Discover Application user counts in the UI, and everything should be back to normal. We appreciate your patience! If you have any questions, please contact Support: support@bettercloud.com
Posted Aug 22, 2022 - 17:24 EDT
Investigating
We are currently investigating an issue that is impacting the visibility of the Discover Application user counts in the UI. We apologize for any inconvenience and will provide another update as soon as possible. If you have any questions, please contact Support: support@bettercloud.com
Posted Aug 19, 2022 - 16:56 EDT
This incident affected: BetterCloud (Applications).