BetterCloud Outage
Incident Report for BetterCloud
Resolved
We have resolved the issue that was preventing users from accessing BetterCloud, and everything should be back to normal. We appreciate your patience. If you have any questions, please contact Support: support@bettercloud.com
Posted 7 months ago. Jul 20, 2018 - 12:52 EDT
Investigating
We are currently investigating an issue that is preventing users from accessing BetterCloud. We will provide another update as soon as we have more information. If you have any questions, please contact Support: support@bettercloud.com
Posted 7 months ago. Jul 20, 2018 - 12:27 EDT
This incident affected: BetterCloud (Core Services).