Access Issues
Incident Report for BetterCloud
Resolved
We have resolved the issue that was preventing users from accessing BetterCloud. Thanks for bearing with us. If you have any questions or concerns, please contact Support: support@bettercloud.com
Posted 9 months ago. Aug 10, 2018 - 16:27 EDT
Monitoring
We have taken action to fix the issue that was preventing users from accessing BetterCloud, and we are monitoring to ensure that everything is back to normal. If you have any questions, please contact Support: support@bettercloud.com
Posted 9 months ago. Aug 10, 2018 - 16:18 EDT
Investigating
We are currently investigating an issue that may prevent users from logging into BetterCloud. We will provide another update as soon as we have more information. If you have any questions, please contact Support: support@bettercloud.com
Posted 9 months ago. Aug 10, 2018 - 15:32 EDT
This incident affected: BetterCloud (Core Services).