Google Compute Engine Outage
Incident Report for BetterCloud
Resolved
The issue delaying Directory syncs has been resolved and Workflows are now triggering as expected. We appreciate your patience. Please contact Support: support@bettercloud.com with any questions.
Posted Jun 04, 2019 - 15:16 EDT
Update
Data is continuing to flow into our system, however some customers may still experience a delay as we process the backlog of tasks. We will continue to monitor and provide updates until we are fully caught up. Please contact Support: support@bettercloud.com with any questions.
Posted Jun 04, 2019 - 09:59 EDT
Monitoring
A fix has been implemented and we are monitoring as we process the backlog of tasks. We will provide another update once everything is caught up.
Posted Jun 03, 2019 - 19:38 EDT
Update
Our teams are continuing to work on a resolution and will provide more information as soon as possible. We apologize for the inconvenience. Please contact Support: support@bettercloud.com with any questions.
Posted Jun 03, 2019 - 16:11 EDT
Update
We are continuing to work on a resolution and will update here as soon as possible. Please contact Support: support@bettercloud.com with any questions.
Posted Jun 03, 2019 - 10:31 EDT
Investigating
We are currently investigating this issue.
Posted Jun 03, 2019 - 08:12 EDT
Update
Unfortunately, we are still experiencing some issues from the Google Compute Engine outage. Directory syncs in app.bettercloud.com may be delayed for some customers. We are working through a resolution and will update this incident once it is resolved. Please contact Support: support@bettercloud.com with any questions.
Posted Jun 03, 2019 - 08:12 EDT
Identified
Users may experience difficulty logging into or loading BetterCloud due to an issue with Google Compute Engine. For details and updates, see https://status.cloud.google.com/incident/compute/19003 . We'll update this incident when BetterCloud is back to normal.
Posted Jun 02, 2019 - 15:55 EDT
This incident affected: BetterCloud (Core Services, Directory).