BetterCloud Not Loading
Incident Report for BetterCloud
Resolved
This incident has been resolved. If you have any questions or concerns, please contact our Support team: support@bettercloud.com
Posted Apr 23, 2020 - 17:30 EDT
Monitoring
Users should once again be able to load BetterCloud. We are monitoring to ensure that all functionality has returned to normal operation. If you have any questions or concerns, please contact our Support team: support@bettercloud.com
Posted Apr 23, 2020 - 17:05 EDT
Investigating
We are currently investigating an issue that is preventing BetterCloud from loading properly. We will provide updates here. If you have any questions, please contact Support: support@bettercloud.com
Posted Apr 23, 2020 - 16:32 EDT
This incident affected: BetterCloud (Core Services).