Files List Not Loading
Incident Report for BetterCloud
Resolved
The Files List is back to working as expected. If you have any questions, please contact Support: support@bettercloud.com
Posted Mar 15, 2018 - 14:19 EDT
Investigating
We are currently investigating an issue that is preventing the Files List from loading. Refreshing the page should populate the expected Files. We will provide another update as soon as possible. If you have any questions, please contact Support: support@bettercloud.com
Posted Mar 15, 2018 - 14:06 EDT