Slack Enterprise Grid Delays
Incident Report for BetterCloud
Resolved
We have resolved the issue that was causing delays for a subset of customers with the Slack Enterprise integration in app.bettercloud.com. We appreciate your patience! If you have any questions, please contact Support: support@bettercloud.com
Posted Mar 21, 2024 - 19:15 EDT
Identified
We have identified an issue causing delays for a subset of customers with the Slack Enterprise integration in app.bettercloud.com and our team is actively working towards a resolution. We will provide another update as soon as possible. If you have any questions, please contact Support: support@bettercloud.com
Posted Mar 21, 2024 - 18:11 EDT
This incident affected: Integrations (Slack Enterprise Grid).