Google Drive trash items will be automatically deleted after 30 days starting on October 13, 2020
Incident Report for BetterCloud
Resolved
This incident has been resolved.
Posted Dec 10, 2020 - 18:57 EST
Monitoring
Due to a change in Google Drive's trash retention policy, Google Drive updates may temporarily take longer than usual to be reflected in the Files list. If you have any questions or concerns, please contact our Support team.
Posted Nov 03, 2020 - 17:21 EST
This incident affected: BetterCloud (Files).