Google Service Disruption
Incident Report for BetterCloud
Resolved
Google has resolved their G Suite and Google Cloud service disruptions. The impact on BetterCloud functionality was minimal. We can confirm Actions and Workflows are working normally. If you have any questions, please contact the Support team.
Posted Mar 26, 2020 - 14:07 EDT
Monitoring
Google has reported G Suite and Google Cloud service disruptions. We are currently investigating whether this has impacted any Actions or Workflows. We are monitoring closely and have only observed intermittent delays in logging in to BetterCloud at this time. If you have any questions, please contact the Support team.
Posted Mar 26, 2020 - 13:09 EDT
This incident affected: Integrations (Google).