Workflow Delays
Incident Report for BetterCloud
Resolved
We have resolved the issue that was causing delays for a subset of workflows, and everything should be back to normal. We appreciate your patience! If you have any questions, please contact Support: support@bettercloud.com
Posted Nov 08, 2023 - 13:00 EST
Monitoring
We have taken action to fix the issue that was causing delays for a subset of workflows, and we are monitoring to ensure that everything is back to normal. We will provide another update as soon as possible. If you have any questions, please contact Support: support@bettercloud.com
Posted Nov 08, 2023 - 12:49 EST
Investigating
We are currently investigating an issue that is causing delays triggering a subset of customer's Workflow instances. We apologize for any inconvenience and will provide another update as soon as possible. If you have any questions, please contact Support: support@bettercloud.com
Posted Nov 08, 2023 - 12:27 EST
This incident affected: BetterCloud (Workflows).