Workflow Delays
Incident Report for BetterCloud
Resolved
We have monitored this issue overnight and all Workflow Action traffic is processing as expected. We appreciate your patience and apologize for any inconvenience this issue may have caused. If you have any questions, please reach out to our Support team by emailing support@bettercloud.com.
Posted Apr 20, 2023 - 13:12 EDT
Identified
We have identified the issue resulting in Workflow Actions delays impacting a limited number of customers and are working to resolve it. We will provide another update as soon as possible. If you have any questions, please contact our Support Team at support@bettercloud.com
Posted Apr 19, 2023 - 14:08 EDT
Investigating
We are investigating an issue that is causing Workflow Action delays for some customers. We are working to resolve this issue as soon as possible and will provide updates here as we work towards a resolution. If you have any questions, please contact our Support Team at support@bettercloud.com
Posted Apr 19, 2023 - 11:16 EDT
This incident affected: BetterCloud (Workflows).