Docusign Integration Outage

Incident Report for BetterCloud

Resolved

This incident has been resolved. Docusign actions should be working as expected. If you have any questions, please contact our Support Team.
Posted Jun 27, 2025 - 16:32 EDT

Identified

We have identified the root cause of an issue that is causing all Docusign actions to fail. As we work towards a resolution, the Docusign integration will not be available for installation in the Integration Center. We apologize for any inconvenience and will provide updates here. If you have any questions, please contact our Support Team.
Posted Jun 04, 2025 - 10:32 EDT
This incident affected: Integrations (Docusign).