Delayed Directory Updates
Incident Report for BetterCloud
Resolved
This incident has been resolved. All delayed events have been processed. If you have any questions, please contact our Support Team.
Posted Aug 03, 2021 - 18:41 EDT
Update
We have measured a sustained decrease in the delayed events buildup since the last deployment. We are continuing to monitor and provide updates in this space and we appreciate your continued patience. If you have any questions, please contact our Support Team at support@bettercloud.com
Posted Aug 03, 2021 - 16:19 EDT
Update
We have deployed another change to help further expedite the delayed syncs. As we continue to monitor and provide updates in this space, we appreciate your continued patience. If you have any questions, please contact our Support Team.
Posted Aug 03, 2021 - 11:14 EDT
Monitoring
We are continuing to monitor as we progress through the backlog of delayed events. We will provide another update tomorrow. If you have any questions, please contact our Support Team.
Posted Aug 02, 2021 - 22:16 EDT
Identified
We have identified the root cause of this issue and implemented some changes that we expect to enable the syncs to start processing more quickly. We will monitor as we process through the delayed events and continue to provide updates on our progress here. If you have any questions, please contact our Support Team.
Posted Aug 02, 2021 - 19:16 EDT
Update
We are continuing to investigate an issue that may cause updates to Users, Groups, Group Memberships, Group Settings, and User Settings to sync in at a delay for the following integrations: Dropbox, Microsoft 365, Okta, and Slack. Workflows configured to trigger based on such updates may run later than expected. We will continue to provide updates here. If you have any questions, please contact our Support Team.
Posted Aug 02, 2021 - 14:35 EDT
Investigating
We are currently investigating an issue that may cause updates to Users, Groups, Group Memberships, Group Settings, and User Settings to sync in at a delay for the following integrations: Dropbox, Microsoft 365, Okta, and Slack. Workflows configured to trigger based on such updates may run later than expected. We will provide another update here as soon as more information is available. If you have any questions, please contact our Support Team.
Posted Aug 02, 2021 - 12:18 EDT
This incident affected: BetterCloud (Directory) and Integrations (Dropbox, Office 365, Okta, Slack).