Chat Widget

Incident Report for BetterCloud

Resolved

This incident has been resolved.
Posted Jul 17, 2020 - 18:37 EDT

Identified

We have identified the chat widget outage as likely related to a wide-scale Internet disruption (see downdetector.com ). Until this is resolved, please continue to email support@bettercloud.com to contact our Support team.
Posted Jul 17, 2020 - 18:01 EDT

Investigating

We are experiencing an issue with our in-app chat support widget. Until it's fixed, you can reach our support team by emailing support@bettercloud.com. We will update this incident as soon as we have more information.
Posted Jul 17, 2020 - 17:34 EDT
This incident affected: Live Chat Widget.