Applications UI Outage
Incident Report for BetterCloud
Resolved
We have resolved the issue that was preventing a subset of customers from loading the Applications page in app.bettercloud.com. We appreciate your patience! If you have any questions, please contact Support: support@bettercloud.com
Posted May 23, 2024 - 13:26 EDT
Monitoring
A potential fix has been implemented and we are monitoring for further issues with the Applications page. If you have any questions or concerns, please contact our Support team.
Posted May 23, 2024 - 09:27 EDT
Identified
Our team continues to work towards remediating the issue preventing a subset of customers from loading the Applications page in app.bettercloud.com. We apologize for any inconvenience this issue may be causing, and will provide another update by 8:00PM EST. If you have any questions, please contact our Support Team by emailing support@bettercloud.com.
Posted May 21, 2024 - 17:05 EDT
Investigating
We have identified an issue preventing a subset of customers from loading the Applications page in app.bettercloud.com. Our team is working to remediate this issue as soon as possible. We apologize for any inconvenience this issue may be causing, and will provide another update by 5:00PM EST. If you have any questions, please contact our Support Team by emailing support@bettercloud.com.
Posted May 21, 2024 - 14:57 EDT
This incident affected: BetterCloud (Applications).