Emails Delayed
Incident Report for BetterCloud
Resolved
The delayed Workflow emails have been reprocessed. This incident has been resolved. If you have any questions, please contact our Support Team at support@bettercloud.com
Posted Sep 30, 2022 - 17:31 EDT
Update
We are working to ensure all Workflow emails that were sent on 9/29/22 between ~7:30AM ET and ~7:30PM ET due to this incident are reprocessed, including emails sent by Send Email, Wait for Approval, Workflow Notifications, Reset Password, and Generate 2 Factor Codes actions. Please note that as we reprocess the delayed emails, some users may receive duplicates of emails that were already sent. Moving forward, email functionality has been restored and should be working as expected. If you have any questions, please contact our Support Team at support@bettercloud.com
Posted Sep 30, 2022 - 13:54 EDT
Monitoring
We have identified and remediated the root cause of the issue affecting BetterCloud emails. Workflow notifications and emails sent by the “Send Email” and “Wait for Approval” actions will be delivered at a delay. We expect to have this resolved soon. If you have any questions, please contact our Support Team at support@bettercloud.com
Posted Sep 29, 2022 - 17:44 EDT
This incident affected: BetterCloud (Workflows).