Unable to save workflows

Incident Report for BetterCloud

Resolved

We have resolved the issue preventing workflows from saving. We appreciate your patience! If you have any questions, please contact our Support Team by emailing support@bettercloud.com.
Posted Jun 16, 2025 - 19:03 EDT

Identified

We have identified an issue in BetterCloud and our team is actively working towards a resolution. We will provide another update as soon as possible. If you have any questions, please contact Support: support@bettercloud.com
Posted Jun 16, 2025 - 14:36 EDT
This incident affected: User Automation (Workflows).