File Governance - Insights Data

Incident Report for BetterCloud

Monitoring

We have taken action to resolve the issue affecting certain customers that was resulting in a File Governance insights data issue. We are monitoring the results and will provide another update as soon as possible. If you have any questions, please contact Support: support@bettercloud.com
Posted Apr 15, 2026 - 14:12 EDT

Identified

We have identified an issue causing File Governance Insights data to be inaccurate for some customers. We are working towards a fix and will provide updates here as we know more. If you have any questions, please reach out to our support team by emailing support@bettercloud.com.
Posted Apr 14, 2026 - 13:44 EDT
This incident affects: File Governance.