Workflows and Actions Delayed
Incident Report for BetterCloud
Resolved
We have resolved the issue that was delaying Workflows/Actions in BetterCloud, and everything should be back to normal. We appreciate your patience! If you have any questions, please contact Support: support@bettercloud.com
Posted Oct 11, 2019 - 12:50 EDT
Identified
We have identified the root cause of an issue that is delaying Workflows and Actions. Our engineers are working on remediating the issue, but Workflows and Actions are executing later than expected. If you have any questions, please contact our Support Team at support@bettercloud.com
Posted Oct 11, 2019 - 09:18 EDT
This incident affected: BetterCloud (Workflows).