Intermittent UI Outage: app.bettercloud.com
Incident Report for BetterCloud
Resolved
This incident has been resolved.
Posted Mar 12, 2024 - 09:24 EDT
Investigating
We are currently investigating an intermittent UI issue impacting a subset of customers. Affected customers may temporarily be unable to load the app.bettercloud.com UI. We will provide another update as soon as possible. If you have any questions, please contact Support: support@bettercloud.com.
Posted Mar 11, 2024 - 12:27 EDT
This incident affected: BetterCloud (Grids / User Interface).