Help Center Outage

Incident Report for BetterCloud

Resolved

We have resolved the issue affecting our help center. We appreciate your patience! If you have any questions, please contact Support: support@bettercloud.com
Posted Jul 02, 2025 - 19:58 EDT

Identified

The help center is currently unavailable due to an issue with our provider (https://help.bettercloud.com). Please use https://support.bettercloud.com/s/knowledge-search as a temporary workaround.
Posted Jul 02, 2025 - 12:21 EDT
This incident affected: Help Center.