Workflows and Actions Delayed
Incident Report for BetterCloud
Resolved
We have taken action to remediate the issue that was delaying Workflows and Actions. Workflows and Actions should be triggering as expected. If you have any questions, please contact our Support Team
Posted 26 days ago. Aug 28, 2019 - 15:41 EDT
Identified
We have identified the root cause of an issue that is delaying Workflows and Actions. Our engineers are working on remediating the issue, but Workflows and Actions are executing later than expected. If you have any questions, please contact our Support Team
Posted about 1 month ago. Aug 21, 2019 - 13:03 EDT
This incident affected: BetterCloud (Workflows).