BetterCloud Access
Incident Report for BetterCloud
Resolved
This incident has been resolved. If you have any questions or concerns, please contact our Support team: support@bettercloud.com
Posted Apr 15, 2020 - 18:22 EDT
Monitoring
We have taken action to fix an issue that was preventing users from accessing BetterCloud. We are monitoring to ensure that all functionality has returned to normal operation. If you have any questions or concerns, please contact our Support team: support@bettercloud.com
Posted Apr 15, 2020 - 17:54 EDT
This incident affected: BetterCloud (Core Services, Alerts, Workflows).