Can't Access BetterCloud
Incident Report for BetterCloud
Resolved
This incident has been resolved. If you have any questions, please contact Support: support@bettercloud.com
Posted Nov 16, 2021 - 13:58 EST
Monitoring
We have identified the root cause of the issue to be a Google Cloud Networking incident. BetterCloud appears to be back up and running and we are monitoring for stability. If you have any questions, please contact Support: support@bettercloud.com
Posted Nov 16, 2021 - 13:18 EST
Investigating
We are currently investigating an issue that is preventing users from accessing BetterCloud. We will provide another update by 1:30pm ET. If you have any questions, please contact Support: support@bettercloud.com
Posted Nov 16, 2021 - 13:01 EST
This incident affected: BetterCloud (Core Services).