Cannot Access BetterCloud
Incident Report for BetterCloud
Resolved
This incident is resolved. Users should be able to access BetterCloud as expected. If you have any questions, please contact Support: support@bettercloud.com
Posted 15 days ago. Aug 08, 2019 - 12:56 EDT
Monitoring
We have taken action to fix issue that was preventing users from accessing BetterCloud and are monitoring to ensure stability. If you have any questions, please contact Support: support@bettercloud.com
Posted 15 days ago. Aug 08, 2019 - 12:42 EDT
Investigating
We are currently investigating an issue that is preventing users from accessing BetterCloud. We apologize for any inconvenience and will provide another update as soon as possible. If you have any questions, please contact Support: support@bettercloud.com
Posted 15 days ago. Aug 08, 2019 - 12:20 EDT
This incident affected: BetterCloud (Core Services).