Monitoring BetterCloud
Incident Report for BetterCloud
Resolved
As of 2:21 AM EDT the remediation effort completed successfully, and everything should be back to normal. We appreciate your patience! If you have any questions, please contact Support: support@bettercloud.com
Posted Jul 30, 2020 - 09:26 EDT
Update
Our Engineering team is continuing work on the remediation effort successfully. We'll continue to provide updates as progress is made. Customers may restore any disconnected Integration directly if desired ahead of this effort.
Posted Jul 29, 2020 - 21:01 EDT
Update
Our Engineering team has started automated remediation to restore Integration connections for those users impacted by this issue. We'll continue to provide updates as progress is made. Users may restore any disconnected Integration directly if desired ahead of this effort. We do apologize for this inconvenience. For any additional assistance, please contact support@bettercloud.com.
Posted Jul 29, 2020 - 19:23 EDT
Update
Our Engineering team identified this issue as related to a Google networking outage: https://status.cloud.google.com/incident/cloud-networking/20008

We are aware that a subset of users have received alerts that certain integrations have been disconnected. Our team is currently investigating this aspect of the incident. Impacted users may reconnect the integration directly from the Integration Center. However, we are investigating a means of restoring disconnected integrations in bulk and will provide updates to this effort as more details become available.
Posted Jul 29, 2020 - 18:03 EDT
Monitoring
Users may have experienced difficulty accessing BetterCloud during a brief outage. We are monitoring to ensure all functionality is stable. Please contact support@bettercloud.com with any questions or concerns.
Posted Jul 29, 2020 - 16:54 EDT
This incident affected: BetterCloud (Core Services).