BetterCloud Login Difficulty
Incident Report for BetterCloud
Resolved
The authentication issue has been resolved. Users should be able to log into BetterCloud with their G Suite accounts as expected.
Posted Aug 19, 2019 - 16:39 EDT
Identified
Google is experiencing an authentication issue that is preventing some users from being able to log into BetterCloud with their G Suite account. We will provide an update here when the issue is resolved.
Posted Aug 19, 2019 - 15:29 EDT
This incident affected: BetterCloud (Core Services) and BetterCloud for G Suite.