Workflow Delay
Incident Report for BetterCloud
Resolved
We have finished processing all tasks and workflows should be triggering as expected for all customers. We appreciate your patience! If you have any questions, please contact Support: support@bettercloud.com
Posted 6 months ago. Aug 30, 2018 - 21:20 EDT
Identified
We have identified the Workflows delay is due to high volume and have taken measure to add more resources to process these tasks faster. We will continue to monitor and provide another update as soon as possible.
Posted 6 months ago. Aug 30, 2018 - 19:25 EDT
Investigating
We are currently investigating an issue that may cause Workflows to trigger at a delay for some customers. We apologize for any inconvenience and will provide another update as soon as possible. If you have any questions, please contact Support: support@bettercloud.com
Posted 6 months ago. Aug 30, 2018 - 18:27 EDT
This incident affected: BetterCloud (Workflows).