BetterCloud not Loading
Incident Report for BetterCloud
Resolved
The issue issue that was preventing BetterCloud from loading as expected is fully resolved. If you have any questions or concerns, please contact our Support team.
Posted Aug 23, 2019 - 17:06 EDT
Monitoring
We have taken action to fix the issue that was preventing users from logging into and/or accessing certain components of BetterCloud. We are monitoring to ensure that we are back up and running. If you have any questions or concerns, please contact our Support team.
Posted Aug 23, 2019 - 15:56 EDT
Investigating
We are investigating the root cause of an issue that is preventing users from logging into and/or accessing certain components of BetterCloud. This is affecting both BetterCloud and our classic interface BetterCloud for G Suite (g.bettercloud.com). We will continue to post updates in this space. If you have any questions or concerns, please contact our Support team.
Posted Aug 23, 2019 - 14:09 EDT
This incident affected: BetterCloud (Core Services) and BetterCloud for G Suite.