Support Outage
Incident Report for BetterCloud
Resolved
This incident has been resolved.
Posted Dec 05, 2022 - 15:40 EST
Identified
Due to a Salesforce outage, our in-app chat widget and help center may be intermittently unavailable at this time. To reach our Support team, please email support@bettercloud.com. Please note that responses may be delayed until our Salesforce access is restored. We will provide updates here as more information becomes available.
Posted Dec 05, 2022 - 12:08 EST
This incident affected: Live Chat Widget.