Workflow Delays
Incident Report for BetterCloud
Resolved
This incident has been resolved.
Posted Aug 01, 2022 - 15:16 EDT
Update
This incident has been resolved as of 12:30PM EST. We apologize for any inconvenience this issue may have caused. If you have any questions, please contact our Support Team at support@bettercloud.com.
Posted Aug 01, 2022 - 13:57 EDT
Investigating
We are investigating an issue that is causing specific Workflow Actions to be delayed in execution. We are working to resolve this issue as soon as possible and will provide updates here as we work towards a resolution. If you have any questions, please contact our Support Team at support@bettercloud.com.
Posted Aug 01, 2022 - 10:36 EDT
This incident affected: BetterCloud (Workflows).