Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 30, 2025 - 19:00 EDT
Update
This maintenance window has been rescheduled for Tuesday, September 30th from 7:00PM to 9:00PM EST.
Posted Sep 23, 2025 - 09:13 EDT
Scheduled
BetterCloud's User Automation (app.bettercloud.com) platform is scheduled to undergo routine maintenance on Tuesday, September 23rd 2025 from 7:00PM to 9:00PM EST.
Within this window, customers will experience the following behavior in both platforms: - Unable to navigate to or load Workflows in app.bettercloud.com - Delays processing and executing all Workflow/Action related functionality, including already in flight Workflows
Note: All delayed Events/Workflows/Actions will resume once maintenance is completed.
Posted Sep 18, 2025 - 17:01 EDT
This scheduled maintenance affected: User Automation (Core Services, Workflows, Workflow Activity Feed).