Errors logging into the application
Incident Report for BetterCloud
Resolved
BetterCloud users should now be able to log in normally. Thank you for your patience. If you have any questions, please contact Support: support@bettercloud.com
Posted Aug 31, 2021 - 16:53 EDT
Identified
We have identified the root cause of an issue preventing users from being able to log into BetterCloud as an outage of a third-party authentication service. We will provide updates in this space as more information becomes available. If you have any questions, please contact Support: support@bettercloud.com
Posted Aug 31, 2021 - 15:55 EDT
This incident affected: BetterCloud (Core Services).