Box Outage
Incident Report for BetterCloud
Resolved
Box has completely recovered from their issue. Box Actions, Workflows, and Alerts should be functioning as expected. Please reach out to support@bettercloud.com if you have any questions or concerns.
Posted 10 months ago. Nov 02, 2018 - 19:17 EDT
Identified
Box has reported an outage that may affect Box Actions, Workflows, and Alerts. See their website for more details. Please reach out to support@bettercloud.com if you have any questions or concerns.
Posted 10 months ago. Nov 02, 2018 - 18:20 EDT
This incident affected: Connectors (Box).