This maintenance window has been scheduled for Wednesday, July 5th, 2023 has been postponed until further notice. We apologize for any interruption. If you have any questions, feel free to reach out to support at support@bettercloud.com
Posted Jun 30, 2023 - 17:40 EDT
Update
This maintenance window has been rescheduled.
BetterCloud will be rescheduling this maintenance window from Monday, July 3rd, 2023 to Wednesday, July 5th, 2023 from 9:00pm to 11:00pm ET.
Within this window, customers may experience temporary disruptions to the Workflow UI, as well as delays in executing Workflow Events and Actions. If you have any questions, feel free to reach out to support at support@bettercloud.com
Posted Jun 26, 2023 - 18:08 EDT
Scheduled
BetterCloud is scheduled to undergo routine maintenance on Monday, July 3rd, 2023 from 9:00pm to 11:00pm ET. Within this window, customers may experience temporary disruptions to the Workflow UI, as well as delays in executing Workflow Events and Actions. If you have any questions, feel free to reach out to support at support@bettercloud.com