Chat Widget
Incident Report for BetterCloud
Resolved
This incident has been resolved.
Posted Nov 02, 2022 - 14:24 EDT
Investigating
We are experiencing an issue with our in-app chat support widget in app.bettercloud.com. Until it's fixed, you can reach our support team by emailing support@bettercloud.com. We will update this incident as soon as we have more information.
Posted Nov 02, 2022 - 09:46 EDT
This incident affected: Live Chat Widget.