Workflow Action Delays

Incident Report for BetterCloud

Resolved

All Workflow Actions that were delayed between 2:30-3:30PM EST have been resolved. We appreciate your patience while we addressed this issue, and apologize for any inconvenience this may have caused. If you have any questions, please contact our Support Team by emailing support@bettercloud.com.
Posted Apr 28, 2025 - 16:30 EDT

Monitoring

We have detected an issue that was causing Workflow Action delays for a subset of customers between 2:30-3:20 pm EST. We have since resolved this issue. However, affected customers may experience residual delays. We will post another update once all residual delays are resolved.

We apologize for any inconvenience this may be causing. If you have any questions, please contact our Support Team by emailing support@bettercloud.com
Posted Apr 28, 2025 - 15:51 EDT
This incident affected: User Automation (Workflows).