File Ingestion Delay

Incident Report for BetterCloud

Resolved

We have resolved the issue causing delays ingesting files for a subset of customers. We appreciate your patience! If you have any questions, please contact our Support Team by emailing support@bettercloud.com.
Posted May 14, 2025 - 00:18 EDT

Monitoring

We have addressed the issue causing delays ingesting Files for a subset of customers. We will continue to monitor and make additional improvements as needed. If you have any questions, please contact our Support Team.
Posted May 13, 2025 - 18:17 EDT

Investigating

We are currently investigating an issue causing delays ingesting Files for a subset of customers. Affected customers may experience delays in Files appearing/updating in the UI, as well as delays triggering File based Automations. If you have any questions, feel free to reach out our Support Team by emailing support@bettercloud.com.
Posted May 13, 2025 - 17:08 EDT
This incident affected: User Automation (Alerts, Files, Data Protection).