App.bettercloud.com Login Outage
Incident Report for BetterCloud
Resolved
We have resolved the issue that was preventing customers from logging into the app.bettercloud.com interface. We appreciate your patience! If you have any questions, please contact Support: support@bettercloud.com
Posted May 15, 2024 - 16:52 EDT
Monitoring
We have taken action to fix the issue that was preventing customers from logging into the app.bettercloud.com interface. We will provide another update as soon as possible. If you have any questions, please contact Support: support@bettercloud.com
Posted May 15, 2024 - 16:12 EDT
Investigating
We are currently investigating an issue that is preventing customers from logging into the app.bettercloud.com interface. We apologize for any inconvenience and will provide another update as soon as possible. If you have any questions, please contact Support: support@bettercloud.com
Posted May 15, 2024 - 15:54 EDT
This incident affected: User Automation (Core Services).