File Governance - Insights Data

Incident Report for BetterCloud

Update

File Governance Insights data remains out-of-date for a subset of customers. We are in the process of implementing further optimizations that should enable us to process the remaining updates more quickly and efficiently. We will continue to provide updates here until Insights data is accurate. If you have any questions, please contact our Support Team.
Posted May 19, 2025 - 10:27 EDT

Monitoring

We have identified an issue causing File Governance Insights data to be out-of-date for some customers. We have taken action to fix the issue and are monitoring as we process the backlog of updates. We expect to be caught up by early next week and will provide another update when Insights data is accurate. If you have any questions, please contact our Support Team.
Posted May 16, 2025 - 11:06 EDT
This incident affects: File Governance.