Support Chat Widget

Incident Report for BetterCloud

Resolved

This incident has been resolved.
Posted Oct 21, 2024 - 13:24 EDT

Investigating

We are experiencing an issue with our in-app chat support widget. Until it's fixed, you can reach our support team by emailing support@bettercloud.com. We will update this incident as soon as we have more information.
Posted Oct 21, 2024 - 09:51 EDT
This incident affected: Live Chat Widget.