app.bettecloud.com Sync Delays

Incident Report for BetterCloud

Resolved

We have resolved the issue that was causing some delays related to the completion of certain Syncs, Alerts, and Workflows for a small subset of customers with Okta, Google, Dropbox and/or Box integrations We appreciate your patience! If you have any questions, please contact Support: support@bettercloud.com
Posted Jun 12, 2024 - 13:42 EDT

Investigating

We have identified and are investigating an issue resulting in some delays related to the completion of certain Syncs, Alerts, and Workflows for a small subset of customers with Okta, Google, Dropbox and/or Box integrations. We apologize for the inconvenience this issue is causing and will post updates as we know more. Please reach out to our support team by emailing support@bettercloud.com if you have any questions
Posted Jun 11, 2024 - 18:52 EDT
This incident affected: User Automation (Alerts, Directory, Files, Workflows) and Integrations (Box, Dropbox, Google, Okta).